로컬 히스토리와의 비교

SVN 및 GIT등과 같은 소스 버전 관리시스템을 사용하고 있지 않은 경우에도, 워크벤치의 과거 버전 보존 기능을 통하여 과거버전과 비교할 수 있습니다.

  1. 비교하려는 eXERD 파일을 더블 클릭하여 에디터를 엽니다.
  2. Window > Show View > Other > History를 선택하여 History 뷰를 엽니다.
    History View 열기

  3. 갱신 툴바 아이템을 눌러, 현재 활성 에디터의 입력파일의 과거 기록을 열거나,
    동기화 버튼을 눌러 항상 활성 에디터의 과거만을 표시하게 합니다.
  4. 과거 버전중 하나를 선택하고, 우클릭하여 현재 버전과 비교(Compare Current with Local)을 선택합니다.
기타

두개의 과거 버전을 선택하여 우클릭 한 뒤, 선택된 두 대상 비교하기(Compare with Each Other)를 선택하여 과거 버전끼리도 비교할 수 있습니다.

비교 모드(Compare Mode) 버튼을 눌러 비교 모드를 활성화 하면, 과거 버전을 더블클릭하여 현재 버전과 비교할 수 있게 됩니다.

SVN 등 별도 소스 관리도구를 사용하는 경우

  1. 과거 버전과 비교하려는 eXERD 파일을 더블 클릭하여 에디터를 엽니다.
  2. Window > Show View > Other > History를 선택하여 History 뷰를 엽니다.
    History View 열기

    사용하시는 플러그인에 따라 UI에 다소 차이가 있을 수 있습니다.

  3. 갱신 툴바 아이템을 눌러, 현재 활성 에디터의 입력파일의 과거 기록을 열거나,
    동기화 버튼을 눌러 항상 활성 에디터의 과거만을 표시하게 합니다.
  4. 과거 버전중 하나를 선택하고, 우클릭하여 Compare를 선택합니다.

  5. 비교할 리비전을 선택하고 OK를 누릅니다.
  6. 비교 뷰어가 열립니다.